dev-lang/go: arm64 stable (bug #721562)
[gentoo.git] / dev-lang / elixir / elixir-1.10.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Elixir programming language"
7 HOMEPAGE="https://elixir-lang.org"
8 SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="Apache-2.0 ErlPL-1.1"
11 SLOT="0"
12 KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc ~sparc x86"
13 IUSE="test"
14
15 RESTRICT="!test? ( test )"
16
17 DEPEND="
18         >=dev-lang/erlang-21:0=[ssl]
19 "
20 # 'mix' tool collides with sci-biology/phylip, bug #537514
21 RDEPEND="${DEPEND}
22         !!sci-biology/phylip
23 "
24 DEPEND+="
25         test? ( dev-vcs/git )
26 "
27
28 PATCHES=(
29         "${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
30         "${FILESDIR}"/${P}-test-regex-fix.patch # backport
31 )
32
33 src_compile() {
34         emake Q=""
35 }
36
37 src_install() {
38         emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" install
39         dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
40 }