dev-qt/qtxml: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-lang / closure-compiler-bin / closure-compiler-bin-20170218.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit java-pkg-2
7
8 DESCRIPTION="JavaScript optimizing compiler"
9 HOMEPAGE="https://github.com/google/closure-compiler"
10 SRC_URI="https://dl.google.com/closure-compiler/compiler-${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND=">=virtual/jre-1.6"
18
19 S=${WORKDIR}
20
21 src_install() {
22         java-pkg_jarinto /opt/${PN}-${SLOT}/lib
23         java-pkg_newjar ${PN%-bin}-v${PV}.jar ${PN}.jar
24         java-pkg_dolauncher \
25                 ${PN%-bin} \
26                 --jar /opt/${PN}-${SLOT}/lib/${PN}.jar \
27                 -into /opt
28         dodoc README.md
29 }