dev-libs/botan: ppc stable wrt bug #574034
[gentoo.git] / dev-lang / bas / bas-2.4.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 inherit autotools eutils toolchain-funcs
7
8 DESCRIPTION="An interpreter for the classic dialect of the programming language BASIC"
9 HOMEPAGE="http://www.moria.de/~michael/bas/"
10 SRC_URI="http://www.moria.de/~michael/bas/${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="lr0"
16
17 RDEPEND="sys-libs/ncurses
18         virtual/libintl"
19 DEPEND="${RDEPEND}
20         sys-devel/gettext"
21
22 src_prepare() {
23         epatch \
24                 "${FILESDIR}"/${PN}-2.1-makefile.patch
25
26         eautoconf
27 }
28
29 src_configure() {
30         tc-export AR
31         econf \
32                 $(use_enable lr0)
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install
37         dodoc NEWS README
38         insinto /usr/share/doc/${PF}/pdf
39         doins bas.pdf
40 }