Merge remote-tracking branch 'remotes/sbraz/pysrt'
[gentoo.git] / dev-java / xp / xp-0.5-r3.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 JAVA_PKG_IUSE="doc source"
8
9 inherit java-pkg-2 java-pkg-simple
10
11 DESCRIPTION="XP is an XML 1.0 parser written in Java"
12 HOMEPAGE="http://www.jclark.com/xml/xp"
13 SRC_URI="ftp://ftp.jclark.com/pub/xml/${PN}.zip -> ${P}.zip"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND="
21         >=virtual/jre-1.6"
22
23 DEPEND="
24         >=virtual/jdk-1.6
25         app-arch/unzip"
26
27 S="${WORKDIR}"
28
29 PATCHES=(
30         "${FILESDIR}/${P}-fix-jdk-1.7-enum.patch"
31 )
32
33 java_prepare() {
34         java-pkg_clean
35         epatch "${PATCHES[@]}"
36 }