dev-java/tomcat-servlet-api: ppc64 stable wrt bug #718020
[gentoo.git] / dev-java / xml-commons-resolver / xml-commons-resolver-1.2-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="An XML Entity and URI Resolver"
11 HOMEPAGE="http://xml.apache.org/commons/"
12 SRC_URI="mirror://apache/xml/commons/${P}.tar.gz"
13
14 KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 LICENSE="Apache-2.0"
16 SLOT="0"
17
18 DEPEND=">=virtual/jdk-1.6"
19 RDEPEND=">=virtual/jre-1.6"
20
21 DOCS=( KEYS LICENSE.resolver.txt NOTICE-resolver.txt )
22
23 S="${WORKDIR}/${P}"
24
25 JAVA_SRC_DIR="src"
26
27 src_prepare() {
28         default
29         java-pkg_clean
30         rm -rv src/org/apache/xml/resolver/tests || die
31 }
32
33 src_install() {
34         java-pkg-simple_src_install
35         einstalldocs
36 }