sci-mathematics/rstudio: Thanks to tomboy-64 for fixing bug Bug 534152 - sci-mathemat...
[gentoo.git] / dev-java / tomcat-native / tomcat-native-1.2.4.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit eutils java-pkg-2 java-ant-2
8
9 DESCRIPTION="Native APR library for Tomcat"
10
11 SLOT="0"
12 SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
13 HOMEPAGE="http://tomcat.apache.org/"
14 KEYWORDS="~amd64 ~x86"
15 LICENSE="Apache-2.0"
16 IUSE="test"
17
18 RDEPEND="dev-libs/apr:1
19         dev-libs/openssl:=
20         >=virtual/jre-1.7"
21
22 DEPEND=">=virtual/jdk-1.7
23         test? ( dev-java/ant-junit:0 )"
24
25 S=${WORKDIR}/${P}-src
26
27 src_configure(){
28         cd native || die
29         econf --with-apr=/usr/bin/apr-1-config  \
30                 --with-ssl=/usr || die "Could not configure native sources"
31 }
32
33 src_compile() {
34         eant jar -f build.xml
35
36         cd native || die
37         default
38 }
39
40 src_install() {
41         java-pkg_newjar "dist/${P}.jar" "${PN}.jar"
42
43         cd native
44         emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
45 }
46
47 src_test() {
48         java-pkg-2_src_test
49 }
50
51 pkg_postinst() {
52         elog
53         elog " APR should be available with Tomcat, for more information"
54         elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
55         elog
56         elog " Please report any bugs to https://bugs.gentoo.org/"
57         elog
58 }