dev-java/sun-jmx: Add RESTRICT=bindist
[gentoo.git] / dev-java / sun-jmx / sun-jmx-1.2.1-r3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 JAVA_PKG_IUSE="doc examples"
7
8 inherit java-pkg-2
9
10 MY_P=jmx-${PV//./_}
11 DESCRIPTION="Java Management Extensions for managing and monitoring"
12 HOMEPAGE="http://www.oracle.com/technetwork/java/javase/tech/javamanagement-140525.html"
13 SRC_URI="${MY_P}-ri.zip"
14
15 LICENSE="Oracle-BCLA-JavaSE"
16 SLOT="0"
17 KEYWORDS="amd64 ~arm ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos"
18 IUSE=""
19
20 DEPEND=">=virtual/jdk-1.4
21         app-arch/unzip"
22 RDEPEND=">=virtual/jre-1.4"
23 RESTRICT="bindist fetch"
24
25 S="${WORKDIR}/${MY_P}-bin"
26
27 DOWNLOADSITE="http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-java-plat-419418.html"
28
29 src_compile() { :; }
30
31 pkg_nofetch() {
32         einfo
33         einfo " Due to license restrictions, we cannot fetch the"
34         einfo " distributables automagically."
35         einfo
36         einfo " 1. Visit ${DOWNLOADSITE} and follow instructions"
37         einfo " 2. Download ${SRC_URI}"
38         einfo " 3. Move file to your DISTDIR directory"
39         einfo " 4. Run emerge on this package again to complete"
40         einfo
41 }
42
43 src_install() {
44         java-pkg_dojar lib/*.jar
45         if use doc; then
46                 java-pkg_dojavadoc doc/api
47                 java-pkg_dohtml -r doc/doc doc/index.html
48         fi
49         use examples && java-pkg_doexamples examples
50 }