dev-java/lucene: Drop maintainer
[gentoo.git] / dev-java / sun-jai-bin / sun-jai-bin-1.1.3-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit java-pkg-2
7
8 MY_PV=${PV//./_}
9 DESCRIPTION="JAI is a class library for managing images"
10 HOMEPAGE="https://jai.dev.java.net/"
11
12 BASE=http://download.java.net/media/jai/builds/release/${MY_PV}
13 MY_P="jai-${MY_PV}"
14 SRC_URI="
15         !amd64? ( ${BASE}/${MY_P}-lib-linux-i586.tar.gz )
16         amd64? ( ${BASE}/${MY_P}-lib-linux-amd64.tar.gz )"
17
18 LICENSE="sun-bcla-jai"
19 SLOT="0"
20 KEYWORDS="amd64"
21 IUSE=""
22
23 DEPEND=""
24 RDEPEND=">=virtual/jre-1.3"
25
26 RESTRICT="bindist mirror"
27 QA_PREBUILT="*"
28
29 S=${WORKDIR}/${MY_P}
30
31 src_prepare() {
32         default
33         rm LICENSE-jai.txt || die
34 }
35
36 src_compile() { :; }
37
38 src_install() {
39         dodoc *.txt
40
41         java-pkg_dojar lib/*.jar
42         use x86 && java-pkg_doso lib/*.so
43         use amd64 && java-pkg_doso lib/*.so
44 }
45
46 pkg_postinst() {
47         elog "This ebuild now installs into /opt/${PN} and /usr/share/${PN}"
48         elog 'To use you need to pass the following to java'
49         if use x86 || use amd64; then
50                 elog '-Djava.library.path=$(java-config -i sun-jai-bin)'
51         fi
52         elog '-classpath $(java-config -p sun-jai-bin)'
53 }