dev-java/tomcat-servlet-api: x86 stable wrt bug #718580
[gentoo.git] / dev-java / stax2-api / stax2-api-4.0.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="Extended Stax (STandard Api for Xml procesing) API"
11 HOMEPAGE="https://github.com/FasterXML/stax2-api"
12 SRC_URI="https://github.com/FasterXML/${PN}/archive/${P}.tar.gz"
13
14 LICENSE="BSD-2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE=""
18
19 RDEPEND="java-virtuals/stax-api:0
20         >=virtual/jre-1.5"
21
22 DEPEND="java-virtuals/stax-api:0
23         >=virtual/jdk-1.5"
24
25 S="${WORKDIR}/${PN}-${P}/src"
26 JAVA_SRC_DIR="main/java"
27 JAVA_GENTOO_CLASSPATH="stax-api"
28
29 src_install() {
30         java-pkg-simple_src_install
31         dodoc ../README.md ../release-notes/VERSION
32 }