dev-java/jboss-logging: update homepage
[gentoo.git] / dev-java / stax2-api / stax2-api-4.0.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="Extended Stax (STandard Api for Xml procesing) API"
11 HOMEPAGE="https://github.com/FasterXML/stax2-api"
12 SRC_URI="https://github.com/FasterXML/${PN}/archive/${P}.tar.gz"
13
14 LICENSE="BSD-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~ppc64 ~x86"
17 IUSE=""
18
19 RDEPEND=">=virtual/jre-1.6"
20 DEPEND=">=virtual/jdk-1.6"
21
22 S="${WORKDIR}/${PN}-${P}/src"
23 JAVA_SRC_DIR="main/java"
24
25 src_install() {
26         java-pkg-simple_src_install
27         dodoc ../README.md ../release-notes/VERSION
28 }