dev-java/tomcat-servlet-api: removed obsolete 8.5.53
[gentoo.git] / dev-java / snip / snip-0.11-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="an Apache ANT optional task that extracts snippets of code from text files"
11 HOMEPAGE="http://www.martiansoftware.com/lab/snip.html"
12 SRC_URI="http://www.martiansoftware.com/lab/${PN}/${P}-src.zip -> ${P}.zip"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
17 IUSE=""
18
19 CDEPEND="dev-java/ant-core:0"
20
21 RDEPEND="
22         ${CDEPEND}
23         >=virtual/jre-1.6"
24
25 DEPEND="
26         ${CDEPEND}
27         >=virtual/jdk-1.6
28         source? ( app-arch/zip )"
29
30 JAVA_GENTOO_CLASSPATH="ant-core"
31
32 java_prepare() {
33         java-pkg_clean
34 }