Merge remote-tracking branch 'github/pr/135'
[gentoo.git] / dev-java / snakeyaml / snakeyaml-1.9-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 JAVA_PKG_IUSE="doc source"
8
9 inherit java-pkg-2 java-pkg-simple
10
11 DESCRIPTION="A YAML 1.1 parser and emitter for Java 5"
12 HOMEPAGE="https://bitbucket.org/asomov/snakeyaml"
13 SRC_URI="https://snakeyaml.googlecode.com/files/SnakeYAML-all-${PV}.zip"
14
15 LICENSE="Apache-2.0"
16 SLOT="1.9"
17 KEYWORDS="amd64 x86"
18 IUSE=""
19
20 DEPEND=">=virtual/jdk-1.5"
21 RDEPEND=">=virtual/jre-1.5"
22
23 S="${WORKDIR}/${PN}"
24 JAVA_SRC_DIR="src/main/java"
25
26 java_prepare() {
27         find "${WORKDIR}" -name '*.class' -exec rm {} +
28
29         # Easier to use java-pkg-simple.
30         rm -v pom.xml || die
31 }
32
33 src_install() {
34         java-pkg-simple_src_install
35         dodoc AUTHORS src/etc/announcement.msg
36 }