dev-java/icedtea-bin: arm64 stable (bug #705992)
[gentoo.git] / dev-java / osgi-foundation / osgi-foundation-1.2.0-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-ant-2
9
10 DESCRIPTION="OSGi R4 Foundation EE by Apache Felix"
11 HOMEPAGE="http://felix.apache.org/"
12 SRC_URI="https://dev.gentoo.org/~tomwij/files/dist/${P}.tar.xz"
13
14 LICENSE="Apache-2.0 OSGi-Specification-2.0"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17
18 DEPEND=">=virtual/jdk-1.5"
19 RDEPEND=">=virtual/jre-1.5"
20
21 java_prepare() {
22         cp "${FILESDIR}"/${P}-build.xml "${S}"/build.xml || die
23 }
24
25 src_install() {
26         java-pkg_newjar target/org.osgi.foundation-${PV}.jar org.osgi.foundation.jar
27 }