dev-java/relaxng-datatype: update homepage
[gentoo.git] / dev-java / osgi-core-api / osgi-core-api-5.0.0-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="OSGi Service Platform Core API (Companion Code)"
11 HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
12 SRC_URI="http://www.osgi.org/download/r5/osgi.core-${PV}.jar"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="amd64 x86 ~amd64-linux"
17 IUSE=""
18
19 RDEPEND="
20         >=virtual/jre-1.6"
21
22 DEPEND="
23         >=virtual/jdk-1.6
24         app-arch/unzip"
25
26 JAVA_SRC_DIR="OSGI-OPT/src"
27
28 java_prepare() {
29         rm -r org || die
30 }