dev-java/icedtea-bin: x86 stable wrt bug #705992
[gentoo.git] / dev-java / offo-hyphenation / offo-hyphenation-2.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="Hyphenation patterns for Apache Fop"
7 HOMEPAGE="http://offo.sourceforge.net"
8 SRC_URI="mirror://sourceforge/offo/${PN}_v${PV}.zip"
9 LICENSE="GPL-2 Apache-2.0 LPPL-1.3b TeX"
10 SLOT="0"
11 KEYWORDS="amd64 ppc64 x86"
12 IUSE="doc"
13
14 RDEPEND=""
15 DEPEND="app-arch/unzip"
16
17 S="${WORKDIR}/${PN}"
18
19 src_compile() { :; }
20
21 src_install() {
22         dodir /usr/share/${PN}/
23         insinto /usr/share/${PN}/
24         doins -r hyph
25
26         if use doc; then
27                 dohtml -r images skin i*.html
28         fi
29 }
30
31 pkg_postinst() {
32         elog "This package installs hyphenation files for several languages"
33         elog "into /usr/share/${PN}/hyph"
34         elog "Check /usr/share/doc/${PF}/html/licenses.html for each file's license."
35         elog "To compile the patterns, install dev-java/fop with USE=hyphenation."
36         elog "Alternatively, use the uncompiled patterns via the <hyphenation-base>"
37         elog "configuration option. See the documentation for more details."
38 }