Merge remote-tracking branch 'github/pr/656'.
[gentoo.git] / dev-java / offo-hyphenation / offo-hyphenation-2.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 DESCRIPTION="Hyphenation patterns for Apache Fop"
8 HOMEPAGE="http://offo.sourceforge.net"
9 SRC_URI="mirror://sourceforge/offo/${PN}_v${PV}.zip"
10 LICENSE="GPL-2 Apache-2.0 LPPL-1.3b TeX"
11 SLOT="0"
12 KEYWORDS="amd64 ppc64 x86"
13 IUSE="doc"
14
15 RDEPEND=""
16 DEPEND="app-arch/unzip"
17
18 S="${WORKDIR}/${PN}"
19
20 src_compile() { :; }
21
22 src_install() {
23         dodir /usr/share/${PN}/
24         insinto /usr/share/${PN}/
25         doins -r hyph
26
27         if use doc; then
28                 dohtml -r images skin i*.html
29         fi
30 }
31
32 pkg_postinst() {
33         elog "This package installs hyphenation files for several languages"
34         elog "into /usr/share/${PN}/hyph"
35         elog "Check /usr/share/doc/${PF}/html/licenses.html for each file's license."
36         elog "To compile the patterns, install dev-java/fop with USE=hyphenation."
37         elog "Alternatively, use the uncompiled patterns via the <hyphenation-base>"
38         elog "configuration option. See the documentation for more details."
39 }