dev-java/openjdk-bin: bump to 11.0.7_p10
[gentoo.git] / dev-java / mockito / mockito-1.9.5-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="A mocking framework for Java"
11 HOMEPAGE="https://github.com/mockito/mockito"
12 SRC_URI="https://${PN}.googlecode.com/files/${P}.zip"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 ppc64 x86"
17
18 IUSE=""
19
20 CDEPEND="dev-java/junit:4
21         dev-java/objenesis:0
22         dev-java/hamcrest-core:0
23         dev-java/ant-core:0"
24 RDEPEND=">=virtual/jre-1.5
25         ${CDEPEND}"
26 DEPEND=">=virtual/jdk-1.5
27         app-arch/unzip
28         ${CDEPEND}"
29
30 S="${WORKDIR}"
31
32 JAVA_SRC_DIR="src"
33 JAVA_GENTOO_CLASSPATH="junit-4,objenesis,hamcrest-core,ant-core"
34
35 src_unpack() {
36         unpack ${A}
37         unzip "${S}"/sources/${PN}-core-${PV}-sources.jar -d src/ || die
38 }
39
40 java_prepare() {
41         find "${S}" -name "*.jar" -delete || die
42 }