Revert "dev-java/java-config: Python 3.8 compatibility"
[gentoo.git] / dev-java / microba / microba-0.4.4.3-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="Swing components for date operations and palettes"
11 HOMEPAGE="https://github.com/tdbear/microba"
12 SRC_URI="https://github.com/tdbear/${PN}/archive/${PV}.zip -> ${P}.zip"
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16
17 CP_DEPEND="dev-java/jgraph:0"
18
19 RDEPEND="${CP_DEPEND}
20         >=virtual/jre-1.6"
21
22 DEPEND="${CP_DEPEND}
23         >=virtual/jdk-1.6"
24
25 S="${WORKDIR}/${P}"
26 JAVA_SRC_DIR="src/main/java"
27
28 DOCS=(
29         change.log.txt
30         readme.txt
31         README.md
32 )
33
34 src_compile() {
35         java-pkg-simple_src_compile
36         java-pkg_addres ${PN}.jar ${JAVA_SRC_DIR}
37 }
38
39 src_install() {
40         default
41         java-pkg-simple_src_install
42 }