dev-java/icedtea: bump to 3.16.0
[gentoo.git] / dev-java / junrar / junrar-0.6.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 JAVA_PKG_IUSE="source doc"
7
8 inherit java-pkg-2 java-pkg-simple vcs-snapshot
9
10 DESCRIPTION="Unrar java implementation"
11 HOMEPAGE="https://github.com/edmund-wagner/junrar/"
12 SRC_URI="https://github.com/edmund-wagner/${PN}/archive/${P}.tar.gz"
13
14 LICENSE="unRAR"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 CDEPEND="
20         dev-java/commons-logging:0
21         dev-java/commons-vfs:2"
22 RDEPEND="${CDEPEND}
23         >=virtual/jre-1.5"
24 DEPEND="
25         ${CDEPEND}
26         >=virtual/jdk-1.5"
27
28 S="${WORKDIR}/${P}"
29
30 JAVA_GENTOO_CLASSPATH="commons-logging,commons-vfs-2"
31 JAVA_SRC_DIR="unrar/src/main/java"
32
33 java_prepare() {
34         find -name "pom.xml" -delete || die
35 }