www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-java / jung / jung-1.7.6-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 JAVA_PKG_IUSE="doc source"
6
7 inherit java-pkg-2 java-pkg-simple
8
9 DESCRIPTION="The Java Universal Network/Graph Framework"
10 HOMEPAGE="http://jung.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 ~ppc64 x86"
16 IUSE=""
17
18 CDEPEND="
19         dev-java/colt:0
20         dev-java/commons-collections:0"
21
22 RDEPEND="
23         ${CDEPEND}
24         >=virtual/jre-1.6"
25
26 DEPEND="
27         ${CDEPEND}
28         app-arch/unzip
29         >=virtual/jdk-1.6"
30
31 JAVA_SRC_DIR="src/edu"
32
33 JAVA_GENTOO_CLASSPATH="
34         colt
35         commons-collections
36 "
37
38 java_prepare() {
39         java-pkg_clean
40 }