dev-java/jdbc-mysql: update homepage
[gentoo.git] / dev-java / jump / jump-0.5-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc examples source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="Java-based extensible high-precision math library"
11 HOMEPAGE="http://jump-math.sourceforge.net/"
12 SRC_URI="mirror://sourceforge/${PN}-math/${P}.tar.gz"
13
14 KEYWORDS="amd64 x86"
15 LICENSE="BSD"
16 SLOT="0"
17
18 RDEPEND="
19         >=virtual/jre-1.6"
20
21 DEPEND="
22         >=virtual/jdk-1.6
23         source? ( app-arch/zip )"
24
25 S="${WORKDIR}/${P}"
26
27 JAVA_SRC_DIR="src/main"
28
29 java_prepare() {
30         rm -rv src/tests || die
31 }
32
33 src_install() {
34         java-pkg-simple_src_install
35         use examples && java-pkg_doexamples src/examples
36 }