sci-chemistry/psi: Chop DESCRIPTION to 80 chars
[gentoo.git] / dev-java / juel / juel-2.1.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 JAVA_PKG_IUSE="doc source"
6
7 inherit java-pkg-2 java-ant-2
8
9 DESCRIPTION="JUEL is an implementation of the Unified Expression Language (EL), a part of JSP 2.1 (JSR-245)"
10 HOMEPAGE="http://juel.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16
17 IUSE=""
18
19 RDEPEND=">=virtual/jre-1.5"
20 DEPEND=">=virtual/jdk-1.5
21                 app-arch/unzip"
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26         rm -v *.jar || die "Unable to remove jars"
27 }
28
29 EANT_BUILD_TARGET="jars"
30 EANT_DOC_TARGET="apidoc"
31
32 src_install() {
33         java-pkg_newjar "${P}.jar"
34         use doc && java-pkg_dojavadoc doc/api
35         use source && java-pkg_dosrc src/api/* src/impl/*
36 }