Merge remote-tracking branch 'github/pr/666'.
[gentoo.git] / dev-java / juel / juel-2.1.0-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 JAVA_PKG_IUSE="doc source"
8
9 inherit java-pkg-2 java-ant-2
10
11 DESCRIPTION="JUEL is an implementation of the Unified Expression Language (EL), a part of JSP 2.1 (JSR-245)"
12 HOMEPAGE="http://juel.sourceforge.net/"
13 SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
14
15 LICENSE="Apache-2.0"
16 SLOT="0"
17 KEYWORDS="~amd64 ~ppc64 ~x86"
18
19 IUSE=""
20
21 RDEPEND=">=virtual/jre-1.6"
22 DEPEND=">=virtual/jdk-1.6
23                 app-arch/unzip"
24
25 java_prepare() {
26         rm -v *.jar || die "Unable to remove jars"
27 }
28
29 EANT_BUILD_TARGET="jars"
30 EANT_DOC_TARGET="apidoc"
31
32 src_install() {
33         java-pkg_newjar "${P}.jar"
34         use doc && java-pkg_dojavadoc doc/api
35         use source && java-pkg_dosrc src/api/* src/impl/*
36 }