dev-java/jdbc-mysql: update homepage
[gentoo.git] / dev-java / jta / jta-1.1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JTA_ZIP="jta-1_1-classes.zip"
7
8 inherit java-pkg-2
9
10 DESCRIPTION="The Java Transaction API"
11 HOMEPAGE="http://www.oracle.com/technetwork/java/javaee/jta/index.html"
12 SRC_URI="${JTA_ZIP}"
13 LICENSE="sun-bcla-jta"
14 SLOT=0
15 KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos"
16
17 DEPEND=" >=virtual/jdk-1.5"
18 RDEPEND=">=virtual/jre-1.5"
19
20 RESTRICT="fetch"
21
22 S="${WORKDIR}"
23
24 pkg_nofetch() {
25         einfo
26         einfo " Due to license restrictions, we cannot fetch the"
27         einfo " distributables automagically."
28         einfo
29         einfo " 1. Visit ${HOMEPAGE}"
30         einfo " 2. Select 'Java Transaction API Specification 1.1 Maintenance Release'"
31         einfo " 3. Download ${JTA_ZIP}"
32         einfo " 4. Move file to your DISTDIR directory"
33         einfo " 5. Restart the emerge process"
34         einfo
35 }
36
37 src_unpack() {
38         unzip -qq "${DISTDIR}"/${JTA_ZIP} || die "failed to unpack"
39 }
40
41 src_compile() {
42         jar cvf jta.jar javax/ || die "failed to create jar"
43 }
44
45 src_install() {
46         java-pkg_dojar jta.jar
47 }