dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-java / json / json-20150729.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 JAVA_PKG_IUSE="doc source"
6
7 inherit java-pkg-2 java-pkg-simple
8
9 DESCRIPTION="Java implementation of the JavaScript Object Notation"
10 HOMEPAGE="https://github.com/douglascrockford/JSON-java"
11 SRC_URI="https://github.com/douglascrockford/JSON-java/archive/${PV}.zip -> ${P}.zip"
12
13 LICENSE="JSON"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 DEPEND=">=virtual/jdk-1.7"
19 RDEPEND=">=virtual/jre-1.7"
20
21 S="${WORKDIR}/JSON-java-${PV}"
22 JAVA_SRC_DIR="src"
23
24 java_prepare() {
25         chmod a-x *.java || die
26         mkdir -p src || die
27         mv *.java src || die
28 }
29
30 src_install() {
31         java-pkg-simple_src_install
32         dodoc README
33 }