dev-java/openjdk: amd64 stable wrt bug #718720
[gentoo.git] / dev-java / jreleaseinfo / jreleaseinfo-1.3.0-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit java-pkg-2 java-ant-2
7
8 DESCRIPTION="Ant Task for build-time creation of Java source file with version or other info"
9 HOMEPAGE="http://jreleaseinfo.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 IUSE="source"
17
18 DEPEND=">=virtual/jdk-1.4
19         app-arch/unzip:0
20         dev-java/ant-core:0
21         source? ( app-arch/zip:0 )"
22
23 RDEPEND=">=virtual/jre-1.4
24         dev-java/ant-core:0"
25
26 EANT_GENTOO_CLASSPATH="ant-core"
27
28 java_prepare() {
29         java-ant_rewrite-classpath build.xml
30 }
31
32 src_install() {
33         java-pkg_newjar "target/${P}.jar"
34
35         dodoc LICENSE.txt
36
37         use source && java-pkg_dosrc src/java/ch
38 }