Revert "dev-java/tomcat-servlet-api: removed obsolete versions"
[gentoo.git] / dev-java / jopt-simple / jopt-simple-5.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="A Java library for parsing command line options"
11 HOMEPAGE="https://pholser.github.com/jopt-simple"
12 SRC_URI="https://github.com/pholser/${PN}/tarball/${P} -> ${P}.tar.gz"
13 LICENSE="MIT"
14 SLOT="0"
15
16 KEYWORDS="amd64 ppc64 x86"
17
18 RDEPEND=">=virtual/jre-1.8"
19 DEPEND=">=virtual/jdk-1.8"
20
21 S="${WORKDIR}/${PN}-${PN}-01719a6"
22
23 JAVA_SRC_DIR="src/main/java"
24
25 src_prepare() {
26         default
27         rm -v pom.xml || die
28 }
29
30 src_install() {
31         einstalldocs
32         java-pkg-simple_src_install
33 }