dev-java/tomcat-servlet-api: ppc64 stable wrt bug #718020
[gentoo.git] / dev-java / jmock / jmock-2.6.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="Library for testing Java code using mock objects"
11 SRC_URI="http://www.jmock.org/downloads/${P}-jars.zip"
12 HOMEPAGE="http://www.jmock.org"
13
14 LICENSE="BSD"
15 SLOT="2"
16 KEYWORDS="amd64 x86"
17 IUSE=""
18
19 CDEPEND="dev-java/hamcrest-core:1.3
20         dev-java/hamcrest-library:1.3
21         dev-java/junit:4"
22
23 RDEPEND=">=virtual/jre-1.6
24         ${CDEPEND}"
25
26 DEPEND=">=virtual/jdk-1.6
27         ${CDEPEND}
28         app-arch/unzip"
29
30 JAVA_GENTOO_CLASSPATH="hamcrest-core-1.3,hamcrest-library-1.3,junit-4"
31
32 S="${WORKDIR}/${P}"
33
34 src_unpack() {
35         unpack ${A}
36         cd "${S}" || die
37         unzip ${P}.jar -d src || die
38         rm *.jar || die
39 }
40
41 src_prepare() {
42         find -name "*.class" -delete || die
43 }