dev-java/sbt-bin: clean up old.
[gentoo.git] / dev-java / jmdns / jmdns-3.4.1-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 JAVA_PKG_IUSE="doc examples source test"
6
7 inherit java-pkg-2 java-pkg-simple
8
9 DESCRIPTION="JmDNS is an implementation of multi-cast DNS in Java"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
11 HOMEPAGE="http://jmdns.sourceforge.net"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~ppc64 x86"
16 IUSE=""
17
18 DEPEND=">=virtual/jdk-1.6"
19 RDEPEND=">=virtual/jre-1.6"
20
21 JAVA_SRC_DIR="src"
22
23 src_prepare() {
24         rm "${S}"/build.xml || die
25         find -name "*.jar" -delete || die
26         find "${JAVA_SRC_DIR}" -name "*Test.java" -delete || die
27 }