Merge github#758: media-sound/mpd: fix the systemd user service
[gentoo.git] / dev-java / jlfgr / jlfgr-1.0-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit versionator java-pkg-2
6
7 MY_PV=$(replace_all_version_separators '_')
8 DESCRIPTION="Java(TM) Look and Feel Graphics Repository"
9 HOMEPAGE="http://java.sun.com/developer/techDocs/hi/repository/"
10 SRC_URI="mirror://gentoo/jlfgr-${MY_PV}.zip"
11
12 LICENSE="sun-jlfgr"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 DEPEND="app-arch/unzip"
18 RDEPEND=">=virtual/jre-1.4"
19 S=${WORKDIR}
20
21 # Empty src_compile() to prevent message about not found build.xml
22 src_compile() { :; }
23
24 src_install() {
25         java-pkg_newjar jlfgr-${MY_PV}.jar ${PN}.jar
26 }