dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-java / jide-oss / jide-oss-3.6.18.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="JIDE Common Layer (Professional Swing Components)"
11 HOMEPAGE="https://github.com/jidesoft/jide-oss"
12 SRC_URI="https://github.com/jidesoft/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13 LICENSE="GPL-2-with-exceptions"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 RDEPEND=">=virtual/jre-1.6"
18 DEPEND=">=virtual/jdk-1.6"
19
20 S="${WORKDIR}/${P}"
21
22 src_prepare() {
23         default
24         rm -rv libs/ src/com/jidesoft/plaf/aqua/ test/ || die
25 }
26
27 src_install() {
28         java-pkg-simple_src_install
29         einstalldocs
30 }