Merge the GLEP 67 transition changes
[gentoo.git] / dev-java / jgoodies-common / jgoodies-common-1.2.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=2
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-ant-2 eutils
9
10 MY_PN="common"
11 MY_PV=${PV//./_}
12 MY_P="${PN}-${MY_PV}"
13 DESCRIPTION="JGoodies Common Library"
14 HOMEPAGE="http://www.jgoodies.com/"
15 SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
16
17 LICENSE="BSD"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 IUSE=""
21
22 DEPEND=">=virtual/jdk-1.5
23         app-arch/unzip"
24 RDEPEND=">=virtual/jre-1.5"
25
26 java_prepare() {
27         # Remove the packaged jars
28         find . -name "*.jar" -delete || die "rm failed"
29 }
30
31 src_compile() {
32         # it does not like unset ${build.compiler.executable}
33         # feel free to fix if you want jikes back
34         java-pkg_filter-compiler jikes
35         # not setting the bootcp breaks ecj, javac apparently ignores nonsense
36         eant -Dbuild.boot.classpath="$(java-config -g BOOTCLASSPATH)" jar
37 }
38
39 src_install() {
40         java-pkg_dojar build/${PN}.jar
41
42         dodoc RELEASE-NOTES.txt README.html || die
43
44         use doc && java-pkg_dohtml -r docs/*
45         use source && java-pkg_dosrc src/core/com
46 }