dev-qt/designer: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-java / jfreesvg / jfreesvg-2.1-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-ant-2
9
10 DESCRIPTION="JFreeSVG is a fast, light-weight, vector graphics library for the Java platform"
11 HOMEPAGE="http://www.jfree.org/jfreesvg/"
12 SRC_URI="mirror://sourceforge/jfreegraphics2d/${P}.zip"
13
14 LICENSE="GPL-3"
15 SLOT="2.1"
16 KEYWORDS="amd64 x86"
17 IUSE="debug"
18
19 DEPEND="
20         app-arch/unzip
21         >=virtual/jdk-1.6"
22
23 RDEPEND="
24         >=virtual/jre-1.6"
25
26 java_prepare() {
27         java-pkg_clean
28 }
29
30 src_compile() {
31         if ! use debug; then
32                 antflags="-Dbuild.debug=false -Dbuild.optimize=true"
33         fi
34         eant -f ant/build.xml compile $(use_doc) $antflags
35 }
36
37 src_install() {
38         java-pkg_newjar "./lib/${P}.jar" ${PN}.jar
39         dodoc README.md
40         use doc && java-pkg_dojavadoc javadoc
41         use source && java-pkg_dosrc src/main/java
42 }