media-gfx/xdot: keyworded 1.1 for ia64, bug #717946
[gentoo.git] / dev-java / jebl / jebl-2013.02.18.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 JAVA_PKG_IUSE="doc"
6
7 inherit java-pkg-2 java-ant-2
8
9 DESCRIPTION="Java Evolutionary Biology Library"
10 HOMEPAGE="http://jebl.sourceforge.net/"
11 SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
12
13 KEYWORDS="amd64 x86"
14 SLOT="0"
15 LICENSE="LGPL-2.1"
16 IUSE=""
17
18 DEPEND=">=virtual/jdk-1.5"
19 RDEPEND=">=virtual/jre-1.5"
20
21 EANT_BUILD_TARGET="dist"
22 EANT_DOC_TARGET="document"
23
24 java_prepare() {
25         rm -rf "${S}/src/org/virion/jam/maconly" || die
26 }
27
28 src_install() {
29         java-pkg_dojar dist/jebl.jar || die
30         java-pkg_dojar dist/jam.jar || die
31         use doc && java-pkg_dojavadoc doc/api
32 }