dev-java/tomcat-servlet-api: x86 stable wrt bug #722654
[gentoo.git] / dev-java / jdbc-postgresql / jdbc-postgresql-9.2_p1003.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-ant-2
9
10 MY_PN="postgresql-jdbc"
11 MY_PV="${PV/_p/-}"
12 MY_P="${MY_PN}-${MY_PV}.src"
13
14 DESCRIPTION="JDBC Driver for PostgreSQL"
15 SRC_URI="https://jdbc.postgresql.org/download/${MY_P}.tar.gz"
16 HOMEPAGE="https://jdbc.postgresql.org/"
17
18 LICENSE="POSTGRESQL"
19 SLOT="0"
20 KEYWORDS="amd64 ppc64 x86"
21 IUSE="test"
22 RESTRICT="!test? ( test )"
23
24 DEPEND="
25         >=virtual/jdk-1.6
26         doc? (
27                 dev-libs/libxslt
28                 app-text/docbook-xsl-stylesheets
29         )
30         test? (
31                 dev-java/ant-junit
32                 dev-db/postgresql[server]
33         )"
34 RDEPEND=">=virtual/jre-1.6"
35
36 S="${WORKDIR}/postgresql-jdbc-${MY_PV}.src"
37
38 java_prepare() {
39         find -name "*.class" -type f -exec rm -v {} + || die
40 }
41
42 JAVA_ANT_REWRITE_CLASSPATH="yes"
43 EANT_DOC_TARGET="publicapi"
44
45 src_compile() {
46         java-pkg-2_src_compile
47
48         # There is a task that creates this doc but I didn't find a way how to use system catalog
49         # to lookup the stylesheet so the 'doc' target is rewritten here to use system call instead.
50         if use doc; then
51                 mkdir -p "${S}/build/doc"
52                 xsltproc -o "${S}/build/doc/pgjdbc.html" http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl \
53                         "${S}/doc/pgjdbc.xml"
54         fi
55 }
56
57 src_test() {
58         einfo "In order to run the tests successfully, you have to have:"
59         einfo "1) PostgreSQL server running"
60         einfo "2) database 'test' defined with user 'test' with password 'password'"
61         einfo "   as owner of the database"
62         einfo "3) plpgsql support in the 'test' database"
63         einfo
64         einfo "You can find a general info on how to perform these steps at"
65         einfo "https://wiki.gentoo.org/wiki/PostgreSQL"
66
67         ANT_TASKS="ant-junit" eant test -Dgentoo.classpath=$(java-pkg_getjars --build-only junit)
68 }
69
70 src_install() {
71         java-pkg_newjar jars/postgresql.jar jdbc-postgresql.jar
72
73         if use doc ; then
74                 java-pkg_dojavadoc build/publicapi
75                 dohtml build/doc/pgjdbc.html
76         fi
77
78         use source && java-pkg_dosrc org
79 }