dev-libs/leatherman: remove installing vendored boost library
[gentoo.git] / dev-java / jclasslib / jclasslib-3.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-ant-2
9
10 DESCRIPTION="Java bytecode viewer"
11 HOMEPAGE="https://github.com/ingokegel/jclasslib"
12 SRC_URI="https://github.com/ingokegel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17
18 DEPEND=">=virtual/jdk-1.6"
19 RDEPEND=">=virtual/jre-1.6"
20
21 src_install() {
22         java-pkg_dojar "build/${PN}.jar"
23
24         java-pkg_dolauncher "${PN}" \
25                 --main org.gjt.jclasslib.browser.BrowserApplication
26
27         use doc && java-pkg_dohtml -r doc/*
28         use source && java-pkg_dosrc src/*
29 }
30
31 pkg_postinst() {
32         elog "jclasslib uses Firefox by default."
33         elog "Set the BROWSER environment at your discretion."
34 }