Merge media-sound/spotify: Fix homepage URL
[gentoo.git] / dev-java / jcip-annotations / jcip-annotations-1.0.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 JAVA_PKG_IUSE="doc source"
8
9 inherit versionator java-pkg-2 java-pkg-simple
10
11 MY_P="${PN}-$(replace_version_separator $(get_last_version_component_index) -)"
12
13 DESCRIPTION="Clean room implementation of the JCIP Annotations"
14 HOMEPAGE="https://github.com/stephenc/jcip-annotations"
15 SRC_URI="https://github.com/stephenc/${PN}/archive/${MY_P}.tar.gz"
16
17 LICENSE="Apache-2.0"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE=""
21
22 RDEPEND=">=virtual/jre-1.5"
23 DEPEND=">=virtual/jdk-1.5"
24
25 S="${WORKDIR}/${PN}-${MY_P}/src"
26 JAVA_SRC_DIR="main/java"
27
28 src_install() {
29         java-pkg-simple_src_install
30         dodoc ../README.md
31 }