dev-java/icedtea-bin: x86 stable wrt bug #705992
[gentoo.git] / dev-java / jchart2d / jchart2d-3.2.2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="A minimalistic realtime charting library for Java"
11 HOMEPAGE="http://jchart2d.sourceforge.net"
12 SRC_URI="mirror://sourceforge/${PN}/${PN}/sources/${PN}-eclipse-project-${PV}.zip"
13 LICENSE="LGPL-2.1+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 RESTRICT="test" # Even the headless tests need a display!?
17
18 CDEPEND="dev-java/jide-oss:0
19         dev-java/xmlgraphics-commons:2"
20
21 RDEPEND=">=virtual/jre-1.6
22         ${CDEPEND}"
23
24 DEPEND=">=virtual/jdk-1.6
25         ${CDEPEND}
26         app-arch/unzip"
27
28 JAVA_GENTOO_CLASSPATH="jide-oss,xmlgraphics-commons-2"
29 JAVA_SRC_DIR="src"
30
31 S="${WORKDIR}/${PN}"
32
33 java_prepare() {
34         rm -rv ext/* || die
35
36         # Ant tries and fails to build these outdated bug
37         # demonstrations. Did Ant's globbing behaviour change?
38         rm -v src/*.java || die
39 }