dev-java/openjdk-jre-bin: revbump to fix cacert path
[gentoo.git] / dev-java / jazzy / jazzy-0.5.2-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc examples source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="Java Spell Check API"
11 HOMEPAGE="https://sourceforge.net/projects/jazzy"
12 SRC_URI="mirror://sourceforge/${PN}/${P}.src.zip -> ${P}.zip"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17
18 IUSE=""
19
20 RDEPEND=">=virtual/jre-1.6"
21
22 DEPEND=">=virtual/jdk-1.6
23                 app-arch/unzip"
24
25 JAVA_SRC_DIR="src"
26
27 java_prepare() {
28         java-pkg_clean
29         rm -rf src/com/swabunga/test || die
30 }
31
32 src_install() {
33         java-pkg-simple_src_install
34
35         use doc && dodoc README.txt
36         use examples && java-pkg_doexamples --subdir \
37                 com/swabunga/spell/examples \
38                 src/com/swabunga/spell/examples
39 }