dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-java / javolution / javolution-6.0.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 # Documentation generation is broken.
7 JAVA_PKG_IUSE="source" # doc
8
9 inherit java-pkg-2 java-ant-2 unpacker
10
11 DESCRIPTION="Java Solution for Real-Time and Embedded Systems"
12 SRC_URI="https://dev.gentoo.org/~tomwij/files/dist/${P}.tar.xz
13         https://dev.gentoo.org/~tomwij/files/dist/${P}-build.xml.tar.xz"
14 HOMEPAGE="http://javolution.org"
15
16 LICENSE="BSD"
17 SLOT="6"
18 KEYWORDS="~amd64 ~x86"
19
20 CDEPEND="dev-java/osgi-core-api:0
21         dev-java/osgi-compendium:0"
22
23 DEPEND=">=virtual/jdk-1.5
24         ${CDEPEND}
25         app-arch/unzip"
26
27 RDEPEND=">=virtual/jre-1.5
28         ${CDEPEND}"
29
30 EANT_BUILD_TARGET="package"
31 JAVA_PKG_BSFIX_NAME="build.xml maven-build.xml"
32 JAVA_ANT_REWRITE_CLASSPATH="yes"
33 EANT_GENTOO_CLASSPATH="osgi-core-api,osgi-compendium"
34
35 src_unpack() {
36         unpacker ${P}.tar.xz
37         cd "${S}" || die
38         unpacker ${P}-build.xml.tar.xz
39 }
40
41 java_prepare() {
42         # Remove bundled libraries.
43         find . -name '*.jar' -print -delete || die
44         find . -name '*.class' -print -delete || die
45
46         epatch "${FILESDIR}"/${P}-javadoc-fix.patch
47 }
48
49 src_install() {
50         java-pkg_newjar core-java/target/${PN}-core-java-${PV}.jar
51
52         dohtml index.html
53
54         # Documentation generation is broken.
55         #use doc && java-pkg_dojavadoc core-java/target/site/apidocs
56         use source && java-pkg_dosrc core-java/src/main/java/${PN}
57 }