sys-libs/readline: stable 8.0_p4 for hppa, bug #719942
[gentoo.git] / dev-java / javahelp / javahelp-2.0.05_p20170719.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 COMMIT="3ca862d8626096770598a3a256886d205246f4a4"
7 JAVA_PKG_IUSE="examples source"
8
9 inherit java-pkg-2 java-ant-2
10
11 DESCRIPTION="The JavaHelp system online help system"
12 HOMEPAGE="https://javaee.github.io/javahelp/"
13 SRC_URI="https://github.com/javaee/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="GPL-2-with-linking-exception"
16 SLOT="0"
17 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
18
19 CDEPEND="java-virtuals/servlet-api:2.4"
20
21 RDEPEND=">=virtual/jre-1.4
22         ${CDEPEND}"
23
24 DEPEND=">=virtual/jdk-1.4
25         ${CDEPEND}"
26
27 S="${WORKDIR}/${PN}-${COMMIT}"
28
29 _eant() {
30         local \
31                 servlet_jar=$(java-pkg_getjar --virtual servlet-api-2.4 servlet-api.jar) \
32                 jsp_jar=$(java-pkg_getjar --virtual servlet-api-2.4 jsp-api.jar)
33
34         eant \
35                 -f javahelp_nbproject/build.xml \
36                 -Dfile.reference.servlet-api.jar="${servlet_jar}" \
37                 -Dfile.reference.jsp-api.jar="${jsp_jar}" \
38                 -Dservlet-jar="${servlet_jar}" \
39                 -Djsp-jar="${jsp_jar}" \
40                 -Dservlet-jar-present=true \
41                 -Djsp-jar-present=true \
42                 -Dtomcat-zip-present=true \
43                 ${@}
44 }
45
46 src_compile() {
47         _eant release
48 }
49
50 #Does not actually run anything
51 #src_test() {
52 #       _eant test
53 #}
54
55 src_install() {
56         java-pkg_dojar javahelp_nbproject/dist/lib/*.jar
57
58         java-pkg_dolauncher jhsearch \
59                 --main com.sun.java.help.search.QueryEngine
60         java-pkg_dolauncher jhindexer \
61                 --main com.sun.java.help.search.Indexer
62
63         use source && java-pkg_dosrc \
64                 jhMaster/JSearch/*/com \
65                 jhMaster/JavaHelp/src/*/{javax,com}
66
67         use examples && java-pkg_doexamples jhMaster/JavaHelp/demos
68 }