dev-util/ccache: arm64 stable (bug #725006)
[gentoo.git] / dev-java / java-sdk-docs / java-sdk-docs-1.8.0.202.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
7
8 [[ "$(ver_cut 4)" == 0 ]] \
9         || MY_PV_EXT="u$(ver_cut 4)"
10
11 MY_PV="$(ver_cut 2)${MY_PV_EXT}"
12
13 DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
14 HOMEPAGE="http://download.oracle.com/javase/8/docs/"
15 SRC_URI="jdk-${MY_PV}-docs-all.zip"
16 LICENSE="oracle-java-documentation-8"
17 SLOT="1.8"
18 KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
19 RESTRICT="fetch"
20
21 DEPEND="app-arch/unzip"
22
23 S="${WORKDIR}/docs"
24
25 pkg_nofetch() {
26         einfo "Please download ${SRC_URI} from"
27         einfo "${DOWNLOAD_URL}"
28         einfo "by agreeing to the license and place it in your distfiles directory."
29         einfo ""
30         einfo "If you find the file on the download page replaced with a higher"
31         einfo "version, please report it in bug #67266 (link below)."
32         einfo ""
33         einfo "If emerge fails because of a checksum error, it is possible that"
34         einfo "the upstream release changed without renaming. Try downloading the file"
35         einfo "again (or a newer revision if available). Otherwise report this to"
36         einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
37 }
38
39 src_prepare() {
40         default
41
42         # Don't need both .Z and .bz2 archives.
43         find -name "*.Z" -delete || die
44 }
45
46 src_install() {
47         insinto /usr/share/doc/${PN}-${SLOT}/html
48         doins -r index.html */
49 }