sci-libs/htslib: Bump to version 1.5
[gentoo.git] / dev-java / java-sdk-docs / java-sdk-docs-1.8.0.144.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit versionator
7
8 DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
9
10 [[ "$(get_version_component_range 4)" == 0 ]] \
11         || MY_PV_EXT="u$(get_version_component_range 4)"
12
13 MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
14 ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
15
16 DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
17 HOMEPAGE="http://download.oracle.com/javase/8/docs/"
18 SRC_URI="${ORIG_NAME}"
19 LICENSE="oracle-java-documentation-8"
20 SLOT="1.8"
21 KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
22 RESTRICT="fetch"
23
24 DEPEND="app-arch/unzip"
25
26 S="${WORKDIR}/docs"
27
28 pkg_nofetch() {
29         einfo "Please download ${ORIG_NAME} from "
30         einfo "${DOWNLOAD_URL}"
31         einfo "(agree to the license) and place it in ${DISTDIR}"
32
33         einfo "If you find the file on the download page replaced with a higher"
34         einfo "version, please report to the bug 67266 (link below)."
35         einfo "If emerge fails because of a checksum error it is possible that"
36         einfo "the upstream release changed without renaming. Try downloading the file"
37         einfo "again (or a newer revision if available). Otherwise report this to"
38         einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
39 }
40
41 src_install(){
42         insinto /usr/share/doc/${P}/html
43         doins -r index.html */
44 }