dev-java/tomcat-servlet-api: amd64 stable wrt bug #718018
[gentoo.git] / dev-java / j2ssh / j2ssh-0.2.9.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 JAVA_PKG_IUSE="source doc examples"
7
8 inherit eutils java-pkg-2 java-ant-2
9
10 DESCRIPTION="Java implementation of the SSH protocol"
11 HOMEPAGE="https://sourceforge.net/projects/sshtools/ http://www.sshtools.com/"
12 SRC_URI="mirror://sourceforge/sshtools/${P}-src.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 CDEPEND="dev-java/commons-logging:0
20         dev-java/ant-core:0"
21
22 RDEPEND="${CDEPEND}
23         >=virtual/jre-1.5"
24 DEPEND="${CDEPEND}
25         >=virtual/jdk-1.5"
26
27 S="${WORKDIR}/${PN}"
28
29 JAVA_ANT_REWRITE_CLASSPATH="yes"
30 EANT_BUILD_TARGET="build"
31 EANT_GENTOO_CLASSPATH="commons-logging,ant-core"
32
33 src_prepare() {
34         epatch "${FILESDIR}/${PV}-no-versioned-jars.patch"
35         epatch "${FILESDIR}/${PV}-extras.patch"
36 }
37
38 src_install() {
39         java-pkg_dojar "${S}"/dist/lib/*.jar
40
41         use doc && java-pkg_dojavadoc docs/
42         use source && java-pkg_dosrc "${S}"/src/com
43         use examples && java-pkg_doexamples "${S}"/examples/
44 }