Merge remote-tracking branch 'github/pr/760'.
[gentoo.git] / dev-java / icu4j / icu4j-53.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 # testdata.jar, icudata.jar and icutzdata.jar do not contain *.class files
8 # but *.res files. These *.res data files are needed to build the final jar.
9
10 JAVA_PKG_IUSE="doc examples source test"
11
12 inherit java-pkg-2 java-ant-2
13
14 DESCRIPTION="A set of Java libraries providing Unicode and Globalization support"
15 HOMEPAGE="http://www.icu-project.org/"
16 SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}-${PV//./_}.tgz"
17
18 LICENSE="icu"
19 SLOT="52"
20 KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
21 IUSE=""
22
23 # Beware of jdk version dependant code #361593
24 DEPEND=">=virtual/jdk-1.6"
25 RDEPEND=">=virtual/jre-1.6"
26
27 S="${WORKDIR}"
28
29 JAVA_PKG_BSFIX_NAME+=" common-targets.xml"
30
31 EANT_DOC_TARGET="docs"
32 EANT_TEST_TARGET="check"
33
34 src_test() {
35         java-pkg-2_src_test
36 }
37
38 src_install() {
39         java-pkg_dojar ${PN}.jar
40         java-pkg_dojar ${PN}-charset.jar
41         java-pkg_dojar ${PN}-localespi.jar
42
43         dohtml readme.html
44
45         use doc && java-pkg_dojavadoc doc
46         use examples && java-pkg_doexamples demos samples
47         use source && java-pkg_dosrc main/classes/*/src/com
48 }