Replace all herds with appropriate projects (GLEP 67)
[gentoo.git] / dev-java / icu4j / icu4j-49.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 # testdata.jar, icudata.jar and icutzdata.jar do not contain *.class files
8 # but *.res files. These *.res data files are needed to build the final jar.
9
10 JAVA_PKG_IUSE="doc examples source test"
11
12 inherit java-pkg-2 java-ant-2
13
14 DESCRIPTION="A set of Java libraries providing Unicode and Globalization support"
15 HOMEPAGE="http://www.icu-project.org/"
16 SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}-${PV//./_}.tgz"
17
18 LICENSE="icu"
19 SLOT="49"
20 KEYWORDS="amd64 ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
21 IUSE=""
22
23 # Beware of jdk version dependant code #361593
24 DEPEND=">=virtual/jdk-1.6"
25 RDEPEND=">=virtual/jre-1.6"
26
27 S="${WORKDIR}"
28
29 JAVA_PKG_BSFIX_NAME+=" common-targets.xml"
30
31 EANT_DOC_TARGET="docs"
32
33 EANT_TEST_TARGET="check"
34
35 src_test() {
36         java-pkg-2_src_test
37 }
38
39 src_install() {
40         java-pkg_dojar "${PN}.jar"
41         java-pkg_dojar "${PN}-charset.jar"
42         java-pkg_dojar "${PN}-localespi.jar"
43
44         dohtml readme.html
45
46         use doc && java-pkg_dojavadoc doc
47         use examples && java-pkg_doexamples demos samples
48         use source && java-pkg_dosrc main/classes/*/src/com
49 }