dev-java/sbt-bin: clean up old.
[gentoo.git] / dev-java / icedtea-sound / icedtea-sound-1.0.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 # Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
5
6 EAPI="5"
7
8 inherit eutils java-pkg-2 prefix
9
10 DESCRIPTION="Plugins for javax.sound"
11 HOMEPAGE="http://icedtea.classpath.org"
12 SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.xz"
13
14 LICENSE="GPL-2-with-linking-exception"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm arm64 ppc64 x86"
17
18 IUSE="+doc test"
19 RESTRICT="!test? ( test )"
20
21 COMMON_DEP="
22         >=virtual/jdk-1.6.0
23         >=media-sound/pulseaudio-0.9.11:="
24 RDEPEND="${COMMON_DEP}"
25 DEPEND="${COMMON_DEP}
26         app-arch/zip"
27
28 pkg_setup() {
29         JAVA_PKG_WANT_SOURCE="1.6"
30         JAVA_PKG_WANT_TARGET="1.6"
31
32         java-pkg-2_pkg_setup
33 }
34
35 src_configure() {
36         econf --with-jdk-home="${JAVA_HOME}" \
37                 $(use_enable doc docs) \
38                 --htmldir="${EROOT}usr/share/doc/${PF}/html"
39 }
40
41 src_compile() {
42         default
43 }