dev-java/guava: Version bump to 20.0, EAPI bump to 6
[gentoo.git] / dev-java / guava / guava-13.0.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 DESCRIPTION="A collection of Google's core Java libraries"
11 HOMEPAGE="https://code.google.com/p/guava-libraries/"
12 SRC_URI="http://search.maven.org/remotecontent?filepath=com/google/${PN}/${PN}/${PV}/${P}-sources.jar"
13
14 LICENSE="Apache-2.0"
15 SLOT="13"
16 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
17
18 COMMON_DEP="
19         dev-java/jsr305:0
20         java-virtuals/jdk-with-com-sun:0"
21 RDEPEND="${COMMON_DEP}
22         || ( virtual/jre:1.7 virtual/jre:1.6 )"
23 DEPEND="${COMMON_DEP}
24         app-arch/unzip
25         virtual/jdk:1.7" # https://code.google.com/p/guava-libraries/issues/detail?id=635
26
27 JAVA_GENTOO_CLASSPATH="jsr305"