Use https by default
[gentoo.git] / dev-java / eclipsito / eclipsito-0_pre20130713.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 JAVA_PKG_IUSE="doc source"
8
9 inherit eutils java-pkg-2 java-ant-2
10
11 DESCRIPTION="A small subset of Eclipse core libraries for modular applications"
12 HOMEPAGE="https://code.google.com/p/eclipsito/"
13 SRC_URI="https://dev.gentoo.org/~tomwij/files/dist/${P}.tar.xz"
14
15 LICENSE="EPL-1.0"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18
19 RDEPEND=">=virtual/jre-1.5"
20 DEPEND=">=virtual/jdk-1.5"
21
22 S="${WORKDIR}/${PN}/org.bardsoftware.${PN}"
23
24 java_prepare() {
25         epatch "${FILESDIR}"/${P}-build.xml
26 }
27
28 src_install() {
29         java-pkg_dojar ${PN}.jar
30
31         use doc && java-pkg_dojavadoc apidocs
32         use source && java-pkg_dosrc src/
33 }