dev-java/tomcat-servlet-api: removed obsolete versions
[gentoo.git] / dev-java / constantine / constantine-0.7-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="source test"
7
8 inherit java-pkg-2 java-ant-2
9
10 DESCRIPTION="Provides Java values for common platform C constants"
11 HOMEPAGE="https://github.com/wmeissner/jnr-constants"
12 SRC_URI="mirror://gentoo/${P}.tar.gz"
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
16 IUSE=""
17
18 RDEPEND=">=virtual/jre-1.6"
19
20 DEPEND=">=virtual/jdk-1.6
21         test? (
22                 dev-java/ant-junit:0
23         )"
24
25 src_compile() {
26         # ecj doesn't like some cast for some reason
27         java-pkg_force-compiler javac
28         java-pkg-2_src_compile
29 }
30
31 src_test() {
32         ANT_TASKS="ant-junit4" eant test -Dlibs.junit_4.classpath="$(java-pkg_getjars --with-dependencies junit-4)"
33 }
34
35 src_install() {
36         java-pkg_dojar dist/${PN}.jar
37         use source && java-pkg_dosrc src/*
38 }